#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^C:\\Box\\Triton Clark Build\\Hull 718\\718 ~ (?!.*rchive|.*scaled_|.*Venues).*[\\].*939-.*\.dwg$"
Local $sString = "C:\Box\Triton Clark Build\Hull 718\718 ~ T0162 - d01f6 - TR01-06.2-ENT\939-0106-0018 - 0106.2-005 - WDT.dwg" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\718 ~ T0162 - d01f6 - TR01-06.2-ENT\939-0106-0019 - 0106.2-009 - WDT.dwg" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\718 ~ T0251 - d02f5 - TR02-05.1-ENT\Rack Models\718 - 939-0205-0010 - 0205.1-011 - YACL.dwg" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\718 ~ T0251 - d02f5 - TR02-05.1-ENT\Rack Models\718 - 939-0205-0011 - 0205.1-012 - YACL.dwg" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\_Mechanical Drawings\10-ENTPRJ\Okugi & RealD files\03_Christie Digital\163-102104-01_Horizon 1LOS Exhaust Duct.STEP" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\_Mechanical Drawings\10-ENTPRJ\VYV Balcony Projectors (ENTPRJ02)\Archive" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\_Mechanical Drawings\10-ENTPRJ\VYV Balcony Projectors (ENTPRJ02)\Bildschirmfoto 2020-09-24 um 11.16.43.png" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\_Mechanical Drawings\10-ENTPRJ\VYV Balcony Projectors (ENTPRJ02)\Bildschirmfoto 2020-09-24 um 11.17.56.png" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\_Shipwide Task Information\QSC Change\718 Triton Dante Bridge.pdf" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\_Shipwide Task Information\QSC Change\Attero Tech to RDL Swap.txt" & @CRLF & _
"C:\Box\Triton Clark Build\Hull 718\_Shipwide Task Information\QSC Change\S718_QSC CABLE CHANGES.xlsm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")