const regex = new RegExp('^C:\\\\Box\\\\Triton Clark Build\\\\Hull 718\\\\718 ~ (?!.*rchive|.*scaled_|.*Venues).*[\\\\].*939-.*\\.dwg$', 'gm')
const str = `C:\\Box\\Triton Clark Build\\Hull 718\\718 ~ T0162 - d01f6 - TR01-06.2-ENT\\939-0106-0018 - 0106.2-005 - WDT.dwg
C:\\Box\\Triton Clark Build\\Hull 718\\718 ~ T0162 - d01f6 - TR01-06.2-ENT\\939-0106-0019 - 0106.2-009 - WDT.dwg
C:\\Box\\Triton Clark Build\\Hull 718\\718 ~ T0251 - d02f5 - TR02-05.1-ENT\\Rack Models\\718 - 939-0205-0010 - 0205.1-011 - YACL.dwg
C:\\Box\\Triton Clark Build\\Hull 718\\718 ~ T0251 - d02f5 - TR02-05.1-ENT\\Rack Models\\718 - 939-0205-0011 - 0205.1-012 - YACL.dwg
C:\\Box\\Triton Clark Build\\Hull 718\\_Mechanical Drawings\\10-ENTPRJ\\Okugi & RealD files\\03_Christie Digital\\163-102104-01_Horizon 1LOS Exhaust Duct.STEP
C:\\Box\\Triton Clark Build\\Hull 718\\_Mechanical Drawings\\10-ENTPRJ\\VYV Balcony Projectors (ENTPRJ02)\\Archive
C:\\Box\\Triton Clark Build\\Hull 718\\_Mechanical Drawings\\10-ENTPRJ\\VYV Balcony Projectors (ENTPRJ02)\\Bildschirmfoto 2020-09-24 um 11.16.43.png
C:\\Box\\Triton Clark Build\\Hull 718\\_Mechanical Drawings\\10-ENTPRJ\\VYV Balcony Projectors (ENTPRJ02)\\Bildschirmfoto 2020-09-24 um 11.17.56.png
C:\\Box\\Triton Clark Build\\Hull 718\\_Shipwide Task Information\\QSC Change\\718 Triton Dante Bridge.pdf
C:\\Box\\Triton Clark Build\\Hull 718\\_Shipwide Task Information\\QSC Change\\Attero Tech to RDL Swap.txt
C:\\Box\\Triton Clark Build\\Hull 718\\_Shipwide Task Information\\QSC Change\\S718_QSC CABLE CHANGES.xlsm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}