#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) (?(DEFINE)" & @CRLF & _
" (?<sep> [ -]?)" & @CRLF & _
" )" & @CRLF & _
" (?<!\d)(?:" & @CRLF & _
" \d{4} (?&sep) \d{4} (?&sep) \d{4} (?&sep) \d{4} # 16 digits" & @CRLF & _
" | \d{3} (?&sep) \d{3} (?&sep) \d{3} (?&sep) \d (?&sep) \d{3} # 13 digits" & @CRLF & _
" | \d{4} (?&sep) \d{6} (?&sep) \d{4} # 14 digits" & @CRLF & _
" | \d{4} (?&sep) \d{6} (?&sep) \d{5} # 15 digit card" & @CRLF & _
" )(?!\d)"
Local $sString = "4111111111111111" & @CRLF & _
"4111 1111 1111 1111" & @CRLF & _
"4111-1111-1111-1111" & @CRLF & _
"" & @CRLF & _
"American Express" & @CRLF & _
"" & @CRLF & _
"378282246310005" & @CRLF & _
"" & @CRLF & _
"American Express" & @CRLF & _
"" & @CRLF & _
"371449635398431" & @CRLF & _
"" & @CRLF & _
"American Express Corporate" & @CRLF & _
"" & @CRLF & _
"378734493671000" & @CRLF & _
"" & @CRLF & _
"Australian BankCard" & @CRLF & _
"" & @CRLF & _
"5610591081018250" & @CRLF & _
"" & @CRLF & _
"Diners Club" & @CRLF & _
"" & @CRLF & _
"30569309025904" & @CRLF & _
"" & @CRLF & _
"Diners Club" & @CRLF & _
"" & @CRLF & _
"38520000023237" & @CRLF & _
"" & @CRLF & _
"Discover" & @CRLF & _
"" & @CRLF & _
"6011111111111117" & @CRLF & _
"" & @CRLF & _
"Discover" & @CRLF & _
"" & @CRLF & _
"6011000990139424" & @CRLF & _
"" & @CRLF & _
"JCB" & @CRLF & _
"" & @CRLF & _
"3530111333300000" & @CRLF & _
"" & @CRLF & _
"JCB" & @CRLF & _
"" & @CRLF & _
"3566002020360505" & @CRLF & _
"" & @CRLF & _
"MasterCard" & @CRLF & _
"" & @CRLF & _
"5555555555554444" & @CRLF & _
"" & @CRLF & _
"MasterCard" & @CRLF & _
"" & @CRLF & _
"5105105105105100" & @CRLF & _
"" & @CRLF & _
"Visa" & @CRLF & _
"" & @CRLF & _
"4111111111111111" & @CRLF & _
"" & @CRLF & _
"Visa" & @CRLF & _
"" & @CRLF & _
"4012888888881881" & @CRLF & _
"" & @CRLF & _
"Visa" & @CRLF & _
"" & @CRLF & _
"4222222222222" & @CRLF & _
"" & @CRLF & _
"Note : Even though this number has a different character count than the other test numbers, it is the correct and functional number." & @CRLF & _
"" & @CRLF & _
"Processor-specific Cards" & @CRLF & _
"" & @CRLF & _
"Dankort (PBS)" & @CRLF & _
"" & @CRLF & _
"76009244561" & @CRLF & _
"" & @CRLF & _
"Dankort (PBS)" & @CRLF & _
"" & @CRLF & _
"5019717010103742" & @CRLF & _
"" & @CRLF & _
"Switch/Solo (Paymentech)" & @CRLF & _
"" & @CRLF & _
"6331101999990016" & @CRLF & _
"" & @CRLF & _
" Visa" & @CRLF & _
"" & @CRLF & _
"4929208147724685" & @CRLF & _
"4539261278252432" & @CRLF & _
"4916790209546242" & @CRLF & _
"4556229836495866" & @CRLF & _
"4556624948936262" & @CRLF & _
" Mastercard" & @CRLF & _
"" & @CRLF & _
"5527513721190671" & @CRLF & _
"5427136938547169" & @CRLF & _
"5501820872619287" & @CRLF & _
"5106667846492187" & @CRLF & _
"5348965176175440" & @CRLF & _
" Discover" & @CRLF & _
"" & @CRLF & _
"6011692621234093" & @CRLF & _
"6011505674384294" & @CRLF & _
"6011686367026051" & @CRLF & _
"6011805238158246" & @CRLF & _
"6011056229327552" & @CRLF & _
" American Express" & @CRLF & _
"" & @CRLF & _
"370831029267044" & @CRLF & _
"345838860105292" & @CRLF & _
"346823285239073" & @CRLF & _
"370750517718351" & @CRLF & _
"340533441239380" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"PHONE NUMBERS:" & @CRLF & _
"" & @CRLF & _
"Local (Canada)" & @CRLF & _
"613-555-0104" & @CRLF & _
"613-555-0141" & @CRLF & _
"613-555-0159" & @CRLF & _
"613-555-0130" & @CRLF & _
"613-555-0163" & @CRLF & _
"613-555-0137" & @CRLF & _
"International (Canada)" & @CRLF & _
"+1-613-555-0104" & @CRLF & _
"+1-613-555-0141" & @CRLF & _
"+1-613-555-0159" & @CRLF & _
"+1-613-555-0130" & @CRLF & _
"+1-613-555-0163" & @CRLF & _
"+1-613-555-0137"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")