using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?(DEFINE)
(?<sep> [ -]?)
)
(?<!\d)(?:
\d{4} (?&sep) \d{4} (?&sep) \d{4} (?&sep) \d{4} # 16 digits
| \d{3} (?&sep) \d{3} (?&sep) \d{3} (?&sep) \d (?&sep) \d{3} # 13 digits
| \d{4} (?&sep) \d{6} (?&sep) \d{4} # 14 digits
| \d{4} (?&sep) \d{6} (?&sep) \d{5} # 15 digit card
)(?!\d)";
string input = @"4111111111111111
4111 1111 1111 1111
4111-1111-1111-1111
American Express
378282246310005
American Express
371449635398431
American Express Corporate
378734493671000
Australian BankCard
5610591081018250
Diners Club
30569309025904
Diners Club
38520000023237
Discover
6011111111111117
Discover
6011000990139424
JCB
3530111333300000
JCB
3566002020360505
MasterCard
5555555555554444
MasterCard
5105105105105100
Visa
4111111111111111
Visa
4012888888881881
Visa
4222222222222
Note : Even though this number has a different character count than the other test numbers, it is the correct and functional number.
Processor-specific Cards
Dankort (PBS)
76009244561
Dankort (PBS)
5019717010103742
Switch/Solo (Paymentech)
6331101999990016
Visa
4929208147724685
4539261278252432
4916790209546242
4556229836495866
4556624948936262
Mastercard
5527513721190671
5427136938547169
5501820872619287
5106667846492187
5348965176175440
Discover
6011692621234093
6011505674384294
6011686367026051
6011805238158246
6011056229327552
American Express
370831029267044
345838860105292
346823285239073
370750517718351
340533441239380
PHONE NUMBERS:
Local (Canada)
613-555-0104
613-555-0141
613-555-0159
613-555-0130
613-555-0163
613-555-0137
International (Canada)
+1-613-555-0104
+1-613-555-0141
+1-613-555-0159
+1-613-555-0130
+1-613-555-0163
+1-613-555-0137";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}