$re = '/href="(http(s)?:\/\/[\w-_.\/]+|#\w+)"/m';
$str = '<a href="http://github.com/den2736">
<a href="https://github.com/den2736">
<a href="#ancor">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);