re = /^((?:https?:)?\/\/)?((?:www|m)\.)?((?:youtube\.com|youtu.be))(\/(?:[\w\-]+\?v=|embed\/|v\/)?)([\w\-]+)(\S+)?$/
str = 'https://www.youtube.com/watch?v=
https://www.youtube.com/watch?v='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end