const regex = /(.*?)(CR\d+)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(CR\\d+)(.*)', 'gm')
const str = `antes before CR1234 after siguiente
antes before CR12345 after siguiente
antes before CR123456 after siguiente`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}