$re = '/(.*?)(CR\d+)(.*)/m';
$str = 'antes before CR1234 after siguiente
antes before CR12345 after siguiente
antes before CR123456 after siguiente';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);