package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([[:alpha:]][[:alpha:][:blank:]]*[[:alpha:]])[[:blank:][:punct:]]+([[:alpha:]][[:alpha:][:blank:]]*[[:alpha:]])[[:blank:]]+([^[]+)\[([0-9]+)\][[:blank:]]*([[:alpha:]]*)$`)
var str = `Calcipotriol - Daivonex Cream 50mcg/1g 30 g [1]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}