re = /^([[:alpha:]][[:alpha:][:blank:]]*[[:alpha:]])[[:blank:][:punct:]]+([[:alpha:]][[:alpha:][:blank:]]*[[:alpha:]])[[:blank:]]+([^[]+)\[([0-9]+)\][[:blank:]]*([[:alpha:]]*)$/
str = 'Calcipotriol - Daivonex Cream 50mcg/1g 30 g [1]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end