using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[,\s:]|^)([\wа-я\-]+)(?=[:,.\s]|$)";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit,
sed do eiusmod tempor incididunt ut labore et dolore magna
aliqua. Ut enim ad minim veniam, quis nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure dolor in reprehenderit in voluptate velit
esse cillum dolore eu :fugiat: nulla pariatur. Excepteur sint
occaecat :cupidatat [non] proident:, sunt in culpa qui officia
deserunt mollit anim id est laborum.
abcdefghijklmnopqrstuvwxyz [ABCDEFGHIJKLMNO] PQRSTUVWXYZ
0123456789 _+-.,!@#$%^&*();\/|<>""'
12345 -98.7 3.141 .6180 9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net <bar.ba@test.co.uk>
www.demo.com {http://foo.co.uk http }
[https://marketplace.visualstudio.com/ite] ms?itemName=chrmarti.regex
https://github.com/chrmarti/vscode-regex asdfasdf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}