$re = '/(?<=[,\s:]|^)([\wа-я\-]+)(?=[:,.\s]|$)/m';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit,
sed do eiusmod tempor incididunt ut labore et dolore magna
aliqua. Ut enim ad minim veniam, quis nostrud exercitation
ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure dolor in reprehenderit in voluptate velit
esse cillum dolore eu :fugiat: nulla pariatur. Excepteur sint
occaecat :cupidatat [non] proident:, sunt in culpa qui officia
deserunt mollit anim id est laborum.
abcdefghijklmnopqrstuvwxyz [ABCDEFGHIJKLMNO] PQRSTUVWXYZ
0123456789 _+-.,!@#$%^&*();\\/|<>"\'
12345 -98.7 3.141 .6180 9,000 +42
555.123.4567 +1-(800)-555-2468
foo@demo.net <bar.ba@test.co.uk>
www.demo.com {http://foo.co.uk http }
[https://marketplace.visualstudio.com/ite] ms?itemName=chrmarti.regex
https://github.com/chrmarti/vscode-regex asdfasdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);