package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((([^:]+:){7}([^:]+))|((([^:]+:)*[^:]+)?::(([^:]+:)*[^:]+)?))(\/.+)$`)
var str = `2001:0DB8:0:CD30::/60`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}