re = /^((([^:]+:){7}([^:]+))|((([^:]+:)*[^:]+)?::(([^:]+:)*[^:]+)?))(\/.+)$/m
str = '2001:0DB8:0:CD30::/60'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end