const regex = /[^abc]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^abc]', 'gm')
const str = `21458 67946,679384u580 8409nf8983 84994994949499499, 12345 abc def aaa bbb ccc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}