re = /[^abc]/m
str = '21458 67946,679384u580 8409nf8983 84994994949499499, 12345 abc def aaa bbb ccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end