using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]+ ([A-Z]* )?([A-Z]+)\n(([A-Z|0-9]*)+ ([A-Z|0-9]* ?)*)?\n([A-Z|0-9)]* )*[A-Z|0-9)]*\n([A-Z|0-9)]* ){1,3}(A[LKSZRAP]|C[AOT]|D[EC]|F[LM]|G[AU]|HI|I[ADL N]|K[SY]|LA|M[ADEHINOPST]|N[CDEHJMVY]|O[HKR]|P[ARW]|RI|S[CD] |T[NX]|UT|V[AIT]|W[AIVY]) [0-9]{5}";
string input = @"JANE DOE DOE
COMPANY1 ASSOCIATES HUB
1960 W CHELSEA AVE STE 2006R
NEW YORK NY 84054";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}