#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^.{5}.)(?:.*)(2004)"
Local $sString = "Nom : Positive Lookbehind" & @CRLF & _
"Description : Cette expression régulière ignore les 7 premiers caractères de la chaîne à vérifier" & @CRLF & _
"Utilitée : Peux notament s'avérer utile lorsque l'on souhaite ignorer les numéros des lignes en début de chaînes en cobol par exemple" & @CRLF & _
"" & @CRLF & _
"■ Exemple 1 :" & @CRLF & _
"" & @CRLF & _
"200420*-2004" & @CRLF & _
"" & @CRLF & _
"■ Exemple 2 :" & @CRLF & _
"" & @CRLF & _
"002003-More : 00 00020401" & @CRLF & _
"002004*-============================================================ 00021001" & @CRLF & _
"002005*-Descent : 16/08/17 at 16:32:59 MemoId : PORCHEYA 00022001" & @CRLF & _
"002006*-Reason : recup pour etre sur bonne version 00023001" & @CRLF & _
"002007*-More : 200418 00024001" & @CRLF & _
"002008*-============================================================ 00030000" & @CRLF & _
"002006*-Descent : 07/07/16 at 14:20:31 MemoId : DALESIAR 00040000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")