re = /(?<=^.{5}.)(?:.*)(2004)/m
str = 'Nom : Positive Lookbehind
Description : Cette expression régulière ignore les 7 premiers caractères de la chaîne à vérifier
Utilitée : Peux notament s\'avérer utile lorsque l\'on souhaite ignorer les numéros des lignes en début de chaînes en cobol par exemple
■ Exemple 1 :
200420*-2004
■ Exemple 2 :
002003-More : 00 00020401
002004*-============================================================ 00021001
002005*-Descent : 16/08/17 at 16:32:59 MemoId : PORCHEYA 00022001
002006*-Reason : recup pour etre sur bonne version 00023001
002007*-More : 200418 00024001
002008*-============================================================ 00030000
002006*-Descent : 07/07/16 at 14:20:31 MemoId : DALESIAR 00040000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end