$re = '/^execute\([a-zA-Z]+\)$/m';
$str = 'execute(any)
execute(math)
execute(maTh)
execute("any")
execute("math")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);