re = /^execute\([a-zA-Z]+\)$/m
str = 'execute(any)
execute(math)
execute(maTh)
execute("any")
execute("math")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end