#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+)$"
Local $sString = "a" & @CRLF & _
"b" & @CRLF & _
"" & @CRLF & _
"c" & @CRLF & _
"d"
Local $sSubst = "----$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)