import re
regex = re.compile(r"^(.+)$", flags=re.MULTILINE)
test_str = ("a\n"
"b\n\n"
"c\n"
"d")
subst = "----$1"
result = regex.sub(subst, test_str)
if result:
print(result)