import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^,]+,[^\\)]+\\)";
final String string = "Player (8, 5) won the $5.40 main pot with a Straight\n"
+ "Player (A, 2) won the $21.00 main pot with a flush\n"
+ " $100.01', 'dd $1,000.05', \n"
+ " 'f 10,000', 'g 100,000',\n"
+ " 'yr 4,120,000.65";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}