use strict;
my $str = 'Player (8, 5) won the $5.40 main pot with a Straight
Player (A, 2) won the $21.00 main pot with a flush
$100.01\', \'dd $1,000.05\',
\'f 10,000\', \'g 100,000\',
\'yr 4,120,000.65';
my $regex = qr/\([^,]+,[^\)]+\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}