const regex = /(?si)(?:^(?<!.)|\R{2}|^Language:\h*[a-zA-Z-]+\R)(?:(?!\R{2}).)*?\bfifa\b.*?(?=\R{2}|\z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?si)(?:^(?<!.)|\\R{2}|^Language:\\h*[a-zA-Z-]+\\R)(?:(?!\\R{2}).)*?\\bfifa\\b.*?(?=\\R{2}|\\z)', 'gm')
const str = `Language: pt-BR
Region: FR
OnlineID: jubtrrzz
---Start---
19 Undertale
Pro Evolution Soccer™ 2018
---END---
Language: pt-BR
Region: FR
OnlineID: jubtrrzz
---Start---
FIFA 19 Undertale
Pro Evolution Soccer™ 2018
---END---
Language: pt-BR
Region: FR
OnlineID: jubtrrzz
---Start---
19 Undertale
Pro Evolution Soccer™ 2018
---END--- `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}