$re = '/(?si)(?:^(?<!.)|\R{2}|^Language:\h*[a-zA-Z-]+\R)(?:(?!\R{2}).)*?\bfifa\b.*?(?=\R{2}|\z)/m';
$str = 'Language: pt-BR
Region: FR
OnlineID: jubtrrzz
---Start---
19 Undertale
Pro Evolution Soccer™ 2018
---END---
Language: pt-BR
Region: FR
OnlineID: jubtrrzz
---Start---
FIFA 19 Undertale
Pro Evolution Soccer™ 2018
---END---
Language: pt-BR
Region: FR
OnlineID: jubtrrzz
---Start---
19 Undertale
Pro Evolution Soccer™ 2018
---END--- ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);