using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[)u?'?([a-zA-Z0-9_\-]+)(?='?\])";
string input = @"Something bad happened! @ data[u'string_1'][u'string_2']['u2'][0]""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}