$re = '/(?<=\[)u?\'?([a-zA-Z0-9_\-]+)(?=\'?\])/';
$str = 'Something bad happened! @ data[u\'string_1\'][u\'string_2\'][\'u2\'][0]"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);