import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)([ ](\\1))+";
final String string = "the little cat cat is in the hat hat hat, we like it.\n"
+ "the little cat cat is in the hat hat hat, we like it.\n"
+ "the little cat cat is in the hat hat hat, we like it.\n"
+ "the little cat cat is in the hat hat hat, we like it.\n"
+ "the the little cat cat is in the hat hat hat, we like it.\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}