re = /(\w+)([ ](\1))+/m
str = 'the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the the little cat cat is in the hat hat hat, we like it.
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result