re = /(?<!\bfor\s)€(\d+(?:,\d+)?)/m
str = 'discount of €50,20 on these items
This item on sale now for €30,20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end