using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.*)\-\>(.*)\]";
string input = @"« ...] une collection de guides ""surprises"" s’adressant tout autant aux visiteurs désireux d’éviter les attrape-touristes qu’aux habitants impatients de dénicher les perles les mieux cachées de leur ville. […] Que l’on souhaite monter dans un bus dont le trajet permet d’admirer les plus beaux monuments de la ville, aller pique-niquer dans un jardin secret en plein cœur du quartier historique ou s’initier à l’art du thé dans une maison d’exception, les guides surprises ont la réponse ! »
(Le Messager.fr, janvier 2015)
[Lire l'article complet->http://loisirs.lemessager.fr/magazine/voyage/europe/article/les-meilleures-adresses-de-la-ville.html]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}