import Foundation
let pattern = #"\[(.*)\-\>(.*)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
« ...] une collection de guides "surprises" s’adressant tout autant aux visiteurs désireux d’éviter les attrape-touristes qu’aux habitants impatients de dénicher les perles les mieux cachées de leur ville. […] Que l’on souhaite monter dans un bus dont le trajet permet d’admirer les plus beaux monuments de la ville, aller pique-niquer dans un jardin secret en plein cœur du quartier historique ou s’initier à l’art du thé dans une maison d’exception, les guides surprises ont la réponse ! »
(Le Messager.fr, janvier 2015)
[Lire l'article complet->http://loisirs.lemessager.fr/magazine/voyage/europe/article/les-meilleures-adresses-de-la-ville.html]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)