$re = '/\\\\b(LLC|Corp|Corporation)\\\\b/m';
$str = 'Corporation This Has a Name LLC AND CoRp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);