re = /\\b(LLC|Corp|Corporation)\\b/m
str = 'Corporation This Has a Name LLC AND CoRp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end