$re = '/[^\s:,]+:[^\s,]+/m';
$str = 'type:1, kind:2, water
something, blu:3, somethingelse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);