re = /[^\s:,]+:[^\s,]+/m
str = 'type:1, kind:2, water
something, blu:3, somethingelse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end