package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[([^\]\[]+)\]\[([^\]\[]+)\]\]`)
var str = `[[two b][three c]]
[[one a]]
[[one a]] and [[two b][three c]]
[[no [match][three c]]
[[no mat]ch][three c]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}