re = /\[\[([^\]\[]+)\]\[([^\]\[]+)\]\]/m
str = '[[two b][three c]]
[[one a]]
[[one a]] and [[two b][three c]]
[[no [match][three c]]
[[no mat]ch][three c]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end