use strict;
my $str = '~teste~~teste~`teste``teste`';
my $regex = qr/[^~`\r\n]+/mp;
my $subst = 'Text';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";