$re = '/[^~`\r\n]+/m';
$str = '~teste~~teste~`teste``teste`';
$subst = "Text";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;