$re = '/[0-9a-zA-Z]{32,34}/m';
$str = 'a37965dcd8421328a767c697448ed735';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);