$re = '/^[^@]+@[^.]+\.[^.]{2,}(\.[^.]{2,})*$/m';
$str = 'jon.skeet@google.com
jon.skeet@google.co.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);