re = /^[^@]+@[^.]+\.[^.]{2,}(\.[^.]{2,})*$/m
str = 'jon.skeet@google.com
jon.skeet@google.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end