using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\<img[^>]+\>)";
string input = @"<div><p><img src=""http://kolhoz1.mosco-web.ru/wa-data/public/blog/img/blog-image-4.png""></p><p>Какой-то текст</p></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}