$re = '/(\<img[^>]+\>)/';
$str = '<div><p><img src="http://kolhoz1.mosco-web.ru/wa-data/public/blog/img/blog-image-4.png"></p><p>Какой-то текст</p></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);