$re = '/^(?=^[\w.@!#$%&\'*+/=?^`{|}~-]{7,254}$)(?<username>(?=^[\w.!#$%&\'*+/=?^`{|}~-]{1,64}@)[\w!#$%&\'*+/=?^`{|}~-]+(?:\.[\w!#$%&\'*+/=?^`{|}~-]+)*)@(?<domain>(?=\b[a-z\d.-]{5,252}$)(?:[a-z\d](?:[a-z\d-]{0,61}[a-z\d])\.)+(?:(?:[a-z](?:[a-z-]{0,61}[a-z]))|(?:(?=[a-z\d-]*?[a-z])(?=[a-z\d-]*?[\d])[a-z\d](?:[a-z\d-]{0,61}[a-z\d]))))$/i';
$str = 'Add the multiline (/m) Regex option for testing or go to te Unit Tests section...
Valid addresses:
test@email.com
Test2@email.com
another.test@email.com
testwith+flag@email.com
withanyofthese#!%$\'&+*-/=?^_.{|}~symbols@email.com
upto64charactersusername56789c123456789d123456789e123456789f1234@email.com
test@with.any.number.of.labels.separated.by.dots.email.com
test@even.with.digits.1234567890.email.com
test@and-hypens-email.com
t@upto252charactersdomainname89c123456789d123456789e123456789f123.butonlyupto63charactersperlabel6789j123456789k123456789l1234567.9m123456789n123456789o123456789p123456789q123456789r123456789s1.3456789t123456789u123456789v123456789w123456789x12.email.com
Invalid adresses:
.usernamestartingwithdot@email.com
usernameendingwithdot.@email.com
havingtwo..consecutivedotsintheusername@email.com
test@orinthedomainname..email.com
test@having.all.numerical.top-level-domain.888
havinglessthan2characterperlabel@1.a.email.com
(havingothersymbolsnotlisted)@email.com
usingotherthanletters.digits.and-hyphens{anddots}inthedomainname@[123.45.67.89]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);