# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=^[\w.@!#$%&'*+/=?^`{|}~-]{7,254}$)(?<username>(?=^[\w.!#$%&'*+/=?^`{|}~-]{1,64}@)[\w!#$%&'*+/=?^`{|}~-]+(?:\.[\w!#$%&'*+/=?^`{|}~-]+)*)@(?<domain>(?=\b[a-z\d.-]{5,252}$)(?:[a-z\d](?:[a-z\d-]{0,61}[a-z\d])\.)+(?:(?:[a-z](?:[a-z-]{0,61}[a-z]))|(?:(?=[a-z\d-]*?[a-z])(?=[a-z\d-]*?[\d])[a-z\d](?:[a-z\d-]{0,61}[a-z\d]))))$"
test_str = ("Add the multiline (/m) Regex option for testing or go to te Unit Tests section...\n\n"
"Valid addresses:\n\n"
"test@email.com\n"
"Test2@email.com\n"
"another.test@email.com\n"
"testwith+flag@email.com\n"
"withanyofthese#!%$'&+*-/=?^_.{|}~symbols@email.com\n"
"upto64charactersusername56789c123456789d123456789e123456789f1234@email.com\n"
"test@with.any.number.of.labels.separated.by.dots.email.com\n"
"test@even.with.digits.1234567890.email.com\n"
"test@and-hypens-email.com\n"
"t@upto252charactersdomainname89c123456789d123456789e123456789f123.butonlyupto63charactersperlabel6789j123456789k123456789l1234567.9m123456789n123456789o123456789p123456789q123456789r123456789s1.3456789t123456789u123456789v123456789w123456789x12.email.com\n\n"
"Invalid adresses:\n\n"
".usernamestartingwithdot@email.com\n"
"usernameendingwithdot.@email.com\n"
"havingtwo..consecutivedotsintheusername@email.com\n"
"test@orinthedomainname..email.com\n"
"test@having.all.numerical.top-level-domain.888\n"
"havinglessthan2characterperlabel@1.a.email.com\n"
"(havingothersymbolsnotlisted)@email.com\n"
"usingotherthanletters.digits.and-hyphens{anddots}inthedomainname@[123.45.67.89]\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.