#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d\d\d\.\d\d\d\.\d\d\d-\d\d|\d\d\.\d\d\d\.\d\d\d\/\d\d\d\d-\d\d(?=\|\d\d\.\d\d\d\.\d\d\d\/\d\d\d\d-\d\d)"
Local $sString = "MARKET S.A.|41.355.058/0001-35| |123,45" & @CRLF & _
"" & @CRLF & _
"MARKET S.A.|41.355.058/0001-35|681.538.156-01|123,45" & @CRLF & _
"" & @CRLF & _
"MARKET S.A.|41.355.058/0001-35|70.092.275/0001-88|123,45"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")